Spurious warning about missing fonts

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Spurious warning about missing fonts

Stefan Radermacher
Hello,

FOP is generating a lot of warning about not finding some of the base-14
fonts, even though I'm not actually using those. When processing my
files, I'm practically inundated with these messages:


Font "Symbol,normal,700" not found. Substituting with "Symbol,normal,400".
Font "ZapfDingbats,normal,700" not found. Substituting with
"ZapfDingbats,normal,400".

I did some research and found this old archived discussion from the
fop-dev list:

http://apache-fop.1065347.n5.nabble.com/ZapfDingbats-and-Symbol-not-found-whereas-they-are-not-needed-td31330.html

and also an entry in FOP's jira tracker:

https://issues.apache.org/jira/browse/FOP-1667

Both seem to indicate that this is the issue I am encountering. However
this problem is practially ancient, is there any chance that this might
get fixed?

Kind regards
Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Spurious warning about missing fonts

Glenn Adams-2
They aren't spurious. You need to find where you are using these fonts (directly or indirectly). It seems you are using bold versions of Symbol and ZapfDingbats.

On Thu, Jul 28, 2016 at 7:11 AM, Stefan Radermacher <[hidden email]> wrote:
Hello,

FOP is generating a lot of warning about not finding some of the base-14
fonts, even though I'm not actually using those. When processing my
files, I'm practically inundated with these messages:


Font "Symbol,normal,700" not found. Substituting with "Symbol,normal,400".
Font "ZapfDingbats,normal,700" not found. Substituting with
"ZapfDingbats,normal,400".

I did some research and found this old archived discussion from the
fop-dev list:

http://apache-fop.1065347.n5.nabble.com/ZapfDingbats-and-Symbol-not-found-whereas-they-are-not-needed-td31330.html

and also an entry in FOP's jira tracker:

https://issues.apache.org/jira/browse/FOP-1667

Both seem to indicate that this is the issue I am encountering. However
this problem is practially ancient, is there any chance that this might
get fixed?

Kind regards
Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Spurious warning about missing fonts

Stefan Radermacher
On 28.07.2016 16:02, Glenn Adams wrote:
> They aren't spurious. You need to find where you are using these
> fonts (directly or indirectly). It seems you are using bold versions
> of Symbol and ZapfDingbats.

I think you misunderstand. I'm not using bold version of these fonts,
but check out the description from the Jira entry:

> When the font-family property hasn't been specified in the FO file,
> it defaults to "sans-serif,Symbol,ZapfDingbats". But the latter two
> aren't available in a bold variant. When a block of text can be
> rendered using the sans-serif family only, warnings are still issued
> about unavailable Symbol bold and ZapfDingbats bold. This is likely
> to puzzle users.

So basically this happens every time you use default font setting and
want to use the bold font.

Regards
Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]