Fwd: fo:float not rendering image fop2.4

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: fo:float not rendering image fop2.4

Alex Muir
Greetings,

I'm having an issue where my images are not displayed within an fo:float using apache fop 2.4 with dita-ot 2.0.1

I created some test output.

I was wondering if you see anything wrong with what I'm doing?

I read over the documentation for fo:float but didn't see any reason why the following wouldn't work.

Regards
Alex


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

topic.fo (38K) Download Attachment
output.pdf (668K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: fo:float not rendering image fop2.4

Chris Bowditch
Hi,

Can you share your XSL-FO file?

Thanks,

Chris

On 11/02/2020 08:33, Alex Muir wrote:

> Greetings,
>
> I'm having an issue where my images are not displayed within an
> fo:float using apache fop 2.4 with dita-ot 2.0.1
>
> I created some test output.
>
> I was wondering if you see anything wrong with what I'm doing?
>
> I read over the documentation for fo:float but didn't see any reason
> why the following wouldn't work.
>
> Regards
> Alex
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: fo:float not rendering image fop2.4

Chris Bowditch
In reply to this post by Alex Muir
Sorry please ignore my first e-mail, I spotted the attachment too late!

I believe the fo:float needs to be a top level block, and not nested
deep within a table

Thanks,

Chris

On 11/02/2020 08:33, Alex Muir wrote:

> Greetings,
>
> I'm having an issue where my images are not displayed within an
> fo:float using apache fop 2.4 with dita-ot 2.0.1
>
> I created some test output.
>
> I was wondering if you see anything wrong with what I'm doing?
>
> I read over the documentation for fo:float but didn't see any reason
> why the following wouldn't work.
>
> Regards
> Alex
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: fo:float not rendering image fop2.4

Alex Muir
Thanks Chris,

Does seem that is the case.

Let me know if I'm wrong, but after reading the restrictions on fo:float in apache documentation, I didn't notice anything to that nature.

Meanwhile I've switched to a different fop engine which renders the float effectively.


On Thu, 13 Feb 2020 at 15:18, Chris Bowditch <[hidden email]> wrote:
Sorry please ignore my first e-mail, I spotted the attachment too late!

I believe the fo:float needs to be a top level block, and not nested
deep within a table

Thanks,

Chris

On 11/02/2020 08:33, Alex Muir wrote:
> Greetings,
>
> I'm having an issue where my images are not displayed within an
> fo:float using apache fop 2.4 with dita-ot 2.0.1
>
> I created some test output.
>
> I was wondering if you see anything wrong with what I'm doing?
>
> I read over the documentation for fo:float but didn't see any reason
> why the following wouldn't work.
>
> Regards
> Alex
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: fo:float not rendering image fop2.4

Chris Bowditch
Its not the level of nesting that is the problem as I first thought, but
the fact you have nested it within a table. From the docs, it says
Floats cannot co-exist with a table:

floats next to a table are not supported unless the start and end of the
table happens in between the start and end of the float

Thanks,

Chris

On 13/02/2020 17:17, Alex Muir wrote:

> Thanks Chris,
>
> Does seem that is the case.
>
> Let me know if I'm wrong, but after reading the restrictions on
> fo:float in apache documentation, I didn't notice anything to that
> nature.
>
> Meanwhile I've switched to a different fop engine which renders the
> float effectively.
>
> Regards
> Alex
> _https://www.linkedin.com/in/alexgmuir/_
>
>
> On Thu, 13 Feb 2020 at 15:18, Chris Bowditch
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Sorry please ignore my first e-mail, I spotted the attachment too
>     late!
>
>     I believe the fo:float needs to be a top level block, and not nested
>     deep within a table
>
>     Thanks,
>
>     Chris
>
>     On 11/02/2020 08:33, Alex Muir wrote:
>     > Greetings,
>     >
>     > I'm having an issue where my images are not displayed within an
>     > fo:float using apache fop 2.4 with dita-ot 2.0.1
>     >
>     > I created some test output.
>     >
>     > I was wondering if you see anything wrong with what I'm doing?
>     >
>     > I read over the documentation for fo:float but didn't see any
>     reason
>     > why the following wouldn't work.
>     >
>     > Regards
>     > Alex
>     >
>     >
>     ---------------------------------------------------------------------
>     > To unsubscribe, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>     > For additional commands, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>
>
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>     For additional commands, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: fo:float not rendering image fop2.4

Alex Muir
Okay thanks,

I'm not sure why I didn't read that.
Could you provide a url to that.


On Tue, 18 Feb 2020 at 09:55, Chris Bowditch <[hidden email]> wrote:
Its not the level of nesting that is the problem as I first thought, but
the fact you have nested it within a table. From the docs, it says
Floats cannot co-exist with a table:

floats next to a table are not supported unless the start and end of the
table happens in between the start and end of the float

Thanks,

Chris

On 13/02/2020 17:17, Alex Muir wrote:
> Thanks Chris,
>
> Does seem that is the case.
>
> Let me know if I'm wrong, but after reading the restrictions on
> fo:float in apache documentation, I didn't notice anything to that
> nature.
>
> Meanwhile I've switched to a different fop engine which renders the
> float effectively.
>
> Regards
> Alex
> _https://www.linkedin.com/in/alexgmuir/_
>
>
> On Thu, 13 Feb 2020 at 15:18, Chris Bowditch
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Sorry please ignore my first e-mail, I spotted the attachment too
>     late!
>
>     I believe the fo:float needs to be a top level block, and not nested
>     deep within a table
>
>     Thanks,
>
>     Chris
>
>     On 11/02/2020 08:33, Alex Muir wrote:
>     > Greetings,
>     >
>     > I'm having an issue where my images are not displayed within an
>     > fo:float using apache fop 2.4 with dita-ot 2.0.1
>     >
>     > I created some test output.
>     >
>     > I was wondering if you see anything wrong with what I'm doing?
>     >
>     > I read over the documentation for fo:float but didn't see any
>     reason
>     > why the following wouldn't work.
>     >
>     > Regards
>     > Alex
>     >
>     >
>     ---------------------------------------------------------------------
>     > To unsubscribe, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>     > For additional commands, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>
>
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>     For additional commands, e-mail:
>     [hidden email]
>     <mailto:[hidden email]>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]