FOP 2.3 and JEuclid

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

FOP 2.3 and JEuclid

Maxime Bégnis-2

Hello,

There is an incompatibility between FOP 2.3 and JEuclid 3.1.9. This because FOP uses Batik 1.10.

The class "org.w3c.dom.events.CustomEvent" in Batik 1.8 has be moved to "org.apache.batik.w3c.dom.events.CustomEvent" in Batik 1.10.

That's the problem I could spot but I don't know if there are others.

I modified and recompile JEuclid core simply changing the import statement in net.sourceforge.jeuclid.elements.presentation.token.Mo and that fixed the issue but I didn't make any intensive test yet. Attached is the patch.

Is that a known issue? If so, is there a well known way to fix it?

Thanks,

--
--
NeoDoc
Maxime Bégnis
[hidden email]
Tél: +33 (0)4.42.52.24.20
789 Rue de La Gare
13770 Venelles
France


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Mo.java.patch (696 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: FOP 2.3 and JEuclid

Simon Steiner

Hi,

 

In order to make batik compile under java 10, we had to rename the namespace since we don’t own org.w3c.

https://issues.apache.org/jira/browse/BATIK-1216

 

Thanks

 

From: Maxime Bégnis <[hidden email]>
Sent: 26 March 2019 08:21
To: [hidden email]
Subject: FOP 2.3 and JEuclid

 

Hello,

There is an incompatibility between FOP 2.3 and JEuclid 3.1.9. This because FOP uses Batik 1.10.

The class "org.w3c.dom.events.CustomEvent" in Batik 1.8 has be moved to "org.apache.batik.w3c.dom.events.CustomEvent" in Batik 1.10.

That's the problem I could spot but I don't know if there are others.

I modified and recompile JEuclid core simply changing the import statement in net.sourceforge.jeuclid.elements.presentation.token.Mo and that fixed the issue but I didn't make any intensive test yet. Attached is the patch.

Is that a known issue? If so, is there a well known way to fix it?

Thanks,

--

--

NeoDoc

Maxime Bégnis

Tél: +33 (0)4.42.52.24.20

789 Rue de La Gare

13770 Venelles

France

Reply | Threaded
Open this post in threaded view
|

RE: FOP 2.3 and JEuclid

Dean Nelson

All,

It would be nice to produce a jEuclid version that could be used with 2.3. Right now I am stuck with FOP 2.2 because of this change. Right now I don’t see any other way to support MathML natively like jEuclid in FOP without a lot of rework.

 

Has anyone tested https://github.com/rototor/jeuclid ?

 

Regards,

Dean Nelson

 

 

From: Simon Steiner <[hidden email]>
Sent: Tuesday, March 26, 2019 3:32 AM
To: [hidden email]
Subject: RE: FOP 2.3 and JEuclid

 

Hi,

 

In order to make batik compile under java 10, we had to rename the namespace since we don’t own org.w3c.

https://issues.apache.org/jira/browse/BATIK-1216

 

Thanks

 

From: Maxime Bégnis <[hidden email]>
Sent: 26 March 2019 08:21
To: [hidden email]
Subject: FOP 2.3 and JEuclid

 

Hello,

There is an incompatibility between FOP 2.3 and JEuclid 3.1.9. This because FOP uses Batik 1.10.

The class "org.w3c.dom.events.CustomEvent" in Batik 1.8 has be moved to "org.apache.batik.w3c.dom.events.CustomEvent" in Batik 1.10.

That's the problem I could spot but I don't know if there are others.

I modified and recompile JEuclid core simply changing the import statement in net.sourceforge.jeuclid.elements.presentation.token.Mo and that fixed the issue but I didn't make any intensive test yet. Attached is the patch.

Is that a known issue? If so, is there a well known way to fix it?

Thanks,

--

--

NeoDoc

Maxime Bégnis

Tél: +33 (0)4.42.52.24.20

789 Rue de La Gare

13770 Venelles

France

Reply | Threaded
Open this post in threaded view
|

RE: FOP 2.3 and JEuclid

Simon Steiner

Hi,

 

The developer of JEuclid will need to be contacted to update their code to work with the newer batik.

 

Thanks

 

From: Dean Nelson <[hidden email]>
Sent: 26 March 2019 16:38
To: [hidden email]
Subject: RE: FOP 2.3 and JEuclid

 

All,

It would be nice to produce a jEuclid version that could be used with 2.3. Right now I am stuck with FOP 2.2 because of this change. Right now I don’t see any other way to support MathML natively like jEuclid in FOP without a lot of rework.

 

Has anyone tested https://github.com/rototor/jeuclid ?

 

Regards,

Dean Nelson

 

 

From: Simon Steiner <[hidden email]>
Sent: Tuesday, March 26, 2019 3:32 AM
To: [hidden email]
Subject: RE: FOP 2.3 and JEuclid

 

Hi,

 

In order to make batik compile under java 10, we had to rename the namespace since we don’t own org.w3c.

https://issues.apache.org/jira/browse/BATIK-1216

 

Thanks

 

From: Maxime Bégnis <[hidden email]>
Sent: 26 March 2019 08:21
To: [hidden email]
Subject: FOP 2.3 and JEuclid

 

Hello,

There is an incompatibility between FOP 2.3 and JEuclid 3.1.9. This because FOP uses Batik 1.10.

The class "org.w3c.dom.events.CustomEvent" in Batik 1.8 has be moved to "org.apache.batik.w3c.dom.events.CustomEvent" in Batik 1.10.

That's the problem I could spot but I don't know if there are others.

I modified and recompile JEuclid core simply changing the import statement in net.sourceforge.jeuclid.elements.presentation.token.Mo and that fixed the issue but I didn't make any intensive test yet. Attached is the patch.

Is that a known issue? If so, is there a well known way to fix it?

Thanks,

--

--

NeoDoc

Maxime Bégnis

Tél: +33 (0)4.42.52.24.20

789 Rue de La Gare

13770 Venelles

France

Reply | Threaded
Open this post in threaded view
|

Re: FOP 2.3 and JEuclid

Maxime Bégnis-2

Hi,

I tested with many formulas and didn't find any problem. It seems to work as it should.

Note that I had a failed automatic test when compiling JEuclid Core :

Results :

Failed tests:
  testConverterSVGtoDOM(net.sourceforge.jeuclid.test.ConverterTest)

Tests run: 56, Failures: 1, Errors: 0, Skipped: 0

Thanks everyone.

--
NeoDoc
Maxime Bégnis
[hidden email]
Tél: +33 (0)4.42.52.24.20
789 Rue de La Gare
13770 Venelles
France
Le 26/03/2019 à 17:48, Simon Steiner a écrit :

Hi,

 

The developer of JEuclid will need to be contacted to update their code to work with the newer batik.

 

Thanks

 

From: Dean Nelson [hidden email]
Sent: 26 March 2019 16:38
To: [hidden email]
Subject: RE: FOP 2.3 and JEuclid

 

All,

It would be nice to produce a jEuclid version that could be used with 2.3. Right now I am stuck with FOP 2.2 because of this change. Right now I don’t see any other way to support MathML natively like jEuclid in FOP without a lot of rework.

 

Has anyone tested https://github.com/rototor/jeuclid ?

 

Regards,

Dean Nelson

 

 

From: Simon Steiner <[hidden email]>
Sent: Tuesday, March 26, 2019 3:32 AM
To: [hidden email]
Subject: RE: FOP 2.3 and JEuclid

 

Hi,

 

In order to make batik compile under java 10, we had to rename the namespace since we don’t own org.w3c.

https://issues.apache.org/jira/browse/BATIK-1216

 

Thanks

 

From: Maxime Bégnis <[hidden email]>
Sent: 26 March 2019 08:21
To: [hidden email]
Subject: FOP 2.3 and JEuclid

 

Hello,

There is an incompatibility between FOP 2.3 and JEuclid 3.1.9. This because FOP uses Batik 1.10.

The class "org.w3c.dom.events.CustomEvent" in Batik 1.8 has be moved to "org.apache.batik.w3c.dom.events.CustomEvent" in Batik 1.10.

That's the problem I could spot but I don't know if there are others.

I modified and recompile JEuclid core simply changing the import statement in net.sourceforge.jeuclid.elements.presentation.token.Mo and that fixed the issue but I didn't make any intensive test yet. Attached is the patch.

Is that a known issue? If so, is there a well known way to fix it?

Thanks,

--

--

NeoDoc

Maxime Bégnis

Tél: +33 (0)4.42.52.24.20

789 Rue de La Gare

13770 Venelles

France